#!/bin/bash
# libgtkhtml.SlackBuild
# Heavily based on the original Slackware build scripts,
# Modified by Stuart Winter
# 02-May-2005
# Record toolchain & other info for the build log:
slackbuildinfo
# Paths to skeleton port's source & real Slackware source tree:
export CWD=$SLACKSOURCE/$PKGSERIES/$PKGNAM
export PORTCWD=$PWD
# Temporary build locations:
export TMPBUILD=$TMP/build-$PKGNAM
export PKG=$TMP/package-$PKGNAM
mkpkgdirs # Delete & re-create temporary directories then cd into $TMPBUILD
# Determine the CFLAGS for the known architectures:
case $ARCH in
arm) export SLKCFLAGS="-O2 -march=armv4t"
export LIBDIRSUFFIX="" ;;
*) export SLKCFLAGS="-O2" ;;
esac
# Extract source:
tar xvvf $CWD/$PKGNAM-$VERSION.tar.bz2
cd $PKGNAM-$VERSION
slackhousekeeping
# Configure:
CFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var/lib \
--disable-accessibility \
--mandir=/usr/man \
--disable-static \
--program-prefix= \
--program-suffix= \
--build=$ARCH-slackware-linux-gnueabi || failconfig
# Build:
make $NUMJOBS || failmake
# Install into package:
make install DESTDIR=$PKG
# Install docs:
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
cp -a AUTHORS COPYING COPYING.LIB NEWS README TODO INSTALL docs/IDEAS \
$PKG/usr/doc/$PKGNAM-$VERSION
# If necessary, start the fakeroot server so we can set file/dir ownerships:
start_fakeroot
# Apply generic Slackware packaging policies:
cd $PKG
slackstripall # strip all .a archives and all ELFs
slackgzpages -i # compress man & info pages and delete usr/info/dir
slackslack # chown -R root:root, chmod -R og-w, slackchown, slack644docs
slackdesc # install slack-desc and doinst.sh
slackmp # run makepkg -l y -c n
# Perform any final checks on the package:
cd $PKG
slackhlinks # search for any hard links